Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2026 - 17:00 UTC
Update
UI Changes
- Payment cancellation controls are being extended so authorised approver users can cancel eligible cheque/manual payment requests without needing full admin access. - The subledger action button has been moved to improve access from the relevant workflow. - Reconciliation actions are being consolidated so unreconcile/undo behaviour is routed through a single, clearer flow while preserving existing user-facing behaviour.
Functional Changes
- Report and journal outputs have been updated with revised columns, removed obsolete tabs/fields, corrected ledger mappings, split debit/credit presentation, and more deterministic journal ordering.
- Premium cancellation ingestion now handles returned fees correctly as negative fee splits. - Data ingestion has been improved so valid rows are not skipped when optional reference fields are missing. - Accounting validation coverage has been expanded for cash fiduciary balance checks and P&L balance checks. - Deferred broker expense handling is being standardised so future-effective broker commission and fees can be deferred and recognised through the normal income-recognition lifecycle.
Operational And Reliability Changes
- SFTP ingestion reliability has been improved around source-file movement/routing, with clearer handling for missing source objects and corrected bucket-level permissions. - Reconciliation status projection is being hardened so deadlocks do not leave premium payment status or read models stale after reconciliation. - Redundant MySQL indexes are being removed to simplify the schema without changing application behaviour. - Automated bank-feed processing has been configured to ignore a designated operational account. - Server and portal CI/runtime alignment is being standardised on Node 22 LTS.
Posted Jul 02, 2026 - 14:18 UTC
Scheduled
Scheduled maintenance will take place between 18:00 and 20:00 British local time.
Posted Apr 30, 2026 - 15:14 UTC
This scheduled maintenance affected: Portal - UK and Backend API.